Main Menu
CODEX® MAV is organized into tabulated windows. Operations selected from menu items appear in corresponding tabs, e.g., gates appear in gating tab.
When experiment is loaded you will see seven menus at the top of the main frame.

File menu

File Menu
In the 'File' menu you can find the following items:
  • Open experiment - Open another experiment instead of currently opened.
  • Open region - Open another region image in addition to currently opened.
  • Open clustering run - Open another clustering run instead of currently opened.
  • Import clustering run - Import clustering run that was not performed in CodexMAV.
  • Open analysis
  • Save analysis
  • Save analysis as - see (Save / Open analysis).
  • Reset experiment - return to the default state of experiment.

Regions Menu

Regions Menu
Regions menu selections include
  • Export as PNG – Export region as PNG
  • Display Best Focus Plane – Disabled when EDF is utilized to process data, because all cells are collapsed into a single z-plane.
  • Intensity Tracking Marker – select a displayed marker (e.g., CD3) to use for intensity tracking when a line scan is made with CTRL+K command.
  • To window – pop out region to window.
  • Close – close region.

Analysis menu

Analysis Menu
In 'Analysis' menu you can click on next items:

Gating Menu

Gating Menu
See Gating Menu for further details.

View menu

All internal frames in the main frame are re-sizable and can be hidden.
Resize / close internal frame
Note: Some items will appear in the 'View' menu only after using them first time. (e.g. Gating, Box plot)
Hide / Show
You can manage the visibility of internal frames through the 'View' menu by clicking on item with corresponding internal frame title. When you click on the 'cross' button of any internal frame it also will become hidden.
Show / Hide all
The fast way to hide or show all internal frames is clicking on 'Hide all' or 'Show all' items in 'View' menu.
Auto-layout
Auto-layout
Also as you can always make changes to the location or size of any internal frame, and you can restore the initial state by clicking on 'Auto-layout' item in 'View' menu.
Background activities
Background activities
One internal frame called 'Backround activities' is hidden by default. You can make it visible and see there information about all long-running tasks such as Voronoi diagram or X-Shift clustering. After any activity is finished you can click on the corresponding 'trash' button to remove this activity from the Background activities panel.

Tools menu

Tools menu
Preferences
Upon clicking on 'Preferences' item in the 'Tools' menu, a frame will appear where the user can change preferences for:
  1. 1.
    Analysis -
    a. Select coloring scheme for heatmaps in Clustering Frame and Population table.
    b. Specify analysis state name prefix.
    c. Specify 'Random generator seed' which will be used in all algorithms with random operations (e.g. X-Shift). This feature allows the users to reproduce the same results when inputting the same parameters (on different machines, with different runs).
  2. 2.
    Populations - Here the users can specify the shape and size of population markers.
  3. 3.
    Export images - Here you can specify image format. This format will be used when you will save different components (gating hierarchy, dendrograms, box plot, etc.)
  4. 4.
    Logging - Here you can pick logging verbosity that you need and via File chooser select folder where all log files will be stored.
Export Voronoi Diagram
Here you can export Voronoi diagram to any selected folder. If the Voronoi diagram has not been calculated yet, you will see an error message.

Help menu

Help menu
Here you can find the following items:
  1. 1.
    About - You will see information about the current version of app and copyright.
  2. 2.
    Online help - After clicking on this item web page with online help will be opened in your web-browser.
  3. 3.
    Feedback - Here you can send feedback by email.
Copy link
Outline